{"action":"Upgrade openssl to 2.0.0 or later.","affected":[{"fixed":"2.0.0","introduced":"0"}],"component":"openssl","cve_ids":["CVE-2016-7798"],"ecosystem":"RubyGems","epss":0.03167,"exploited":false,"fixed_versions":["2.0.0"],"ghsa_id":"GHSA-6h88-qjpv-p32m","id":"tcs_01M5KEHBRX8ZTPS1CKWVR472AN","modified_at":"2024-02-16T08:20:58.750802Z","published_at":"2017-10-24T18:33:35Z","references":["https://osv.dev/vulnerability/GHSA-6h88-qjpv-p32m","https://nvd.nist.gov/vuln/detail/CVE-2016-7798","https://github.com/ruby/openssl/issues/49","https://github.com/ruby/openssl/commit/8108e0a6db133f3375608303fdd2083eb5115062","https://github.com/advisories/GHSA-6h88-qjpv-p32m","https://github.com/ruby/openssl","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/openssl/CVE-2016-7798.yml","https://lists.debian.org/debian-lts-announce/2018/07/msg00012.html","https://web.archive.org/web/20210121065227/https://www.securityfocus.com/bid/93031/info","https://www.debian.org/security/2017/dsa-3966","http://www.openwall.com/lists/oss-security/2016/09/19/9","http://www.openwall.com/lists/oss-security/2016/09/30/6","http://www.openwall.com/lists/oss-security/2016/10/01/2"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-6h88-qjpv-p32m","url":"https://osv.dev/vulnerability/GHSA-6h88-qjpv-p32m"}],"summary":"OpenSSL gem for Ruby using inadequate encryption strength"}