{"action":"Upgrade job-iteration to 1.11 or later.","affected":[{"fixed":"1.11","introduced":"0"}],"component":"job-iteration","cve_ids":["CVE-2025-53623"],"ecosystem":"RubyGems","epss":0.00833,"exploited":false,"fixed_versions":["1.11"],"ghsa_id":"GHSA-6qjf-g333-pv38","id":"tcs_01M5KEHCXGA2QYT54Z7S1TSKBY","modified_at":"2025-08-20T23:33:56.765583Z","published_at":"2025-07-14T17:55:06Z","references":["https://osv.dev/vulnerability/GHSA-6qjf-g333-pv38","https://github.com/Shopify/job-iteration/security/advisories/GHSA-6qjf-g333-pv38","https://nvd.nist.gov/vuln/detail/CVE-2025-53623","https://github.com/Shopify/job-iteration/pull/595","https://github.com/Shopify/job-iteration/commit/1a7adfdd041105a5e45e774cadc6b973a292ba55","https://github.com/Shopify/job-iteration","https://github.com/Shopify/job-iteration/releases/tag/v1.11.0","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/job-iteration/CVE-2025-53623.yml"],"severity":{"label":"high","score":8.1},"sources":[{"source":"osv","source_id":"GHSA-6qjf-g333-pv38","url":"https://osv.dev/vulnerability/GHSA-6qjf-g333-pv38"},{"source":"nvd","source_id":"CVE-2025-53623","url":"https://nvd.nist.gov/vuln/detail/CVE-2025-53623"}],"summary":"Job Iteration API is vulnerable to OS Command Injection attack through its CsvEnumerator class"}