{"action":"Upgrade nokogiri to 1.8.5 or later.","affected":[{"fixed":"1.8.5","introduced":"0"}],"component":"nokogiri","cve_ids":["CVE-2018-14404"],"ecosystem":"RubyGems","epss":0.03748,"exploited":false,"fixed_versions":["1.8.5"],"ghsa_id":"GHSA-6qvp-r6r3-9p7h","id":"tcs_01M5KEHD2H2J78K3835DS4B5JA","modified_at":"2025-12-05T12:28:29.328953Z","published_at":"2019-01-17T14:05:03Z","references":["https://osv.dev/vulnerability/GHSA-6qvp-r6r3-9p7h","https://nvd.nist.gov/vuln/detail/CVE-2018-14404","https://github.com/sparklemotion/nokogiri/issues/1785","https://access.redhat.com/errata/RHSA-2019:1543","https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=901817","https://bugzilla.redhat.com/show_bug.cgi?id=1595985","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/nokogiri/CVE-2018-14404.yml","https://gitlab.gnome.org/GNOME/libxml2/issues/10","https://lists.debian.org/debian-lts-announce/2018/09/msg00035.html","https://lists.debian.org/debian-lts-announce/2020/09/msg00009.html","https://security.netapp.com/advisory/ntap-20190719-0002","https://usn.ubuntu.com/3739-1","https://usn.ubuntu.com/3739-2"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-6qvp-r6r3-9p7h","url":"https://osv.dev/vulnerability/GHSA-6qvp-r6r3-9p7h"}],"summary":"Nokogiri NULL Pointer Dereference"}