{"action":"Upgrade nokogiri to 1.5.4 or later.","affected":[{"fixed":"1.5.4","introduced":"0"}],"component":"nokogiri","cve_ids":["CVE-2012-6685"],"ecosystem":"RubyGems","epss":0.02168,"exploited":false,"fixed_versions":["1.5.4"],"ghsa_id":"GHSA-6wj9-77wq-jq7p","id":"tcs_01M5KEHDPDW0W8Z1JKCDK3BM00","modified_at":"2023-11-08T03:57:12.130741Z","published_at":"2022-04-23T00:40:45Z","references":["https://osv.dev/vulnerability/GHSA-6wj9-77wq-jq7p","https://nvd.nist.gov/vuln/detail/CVE-2012-6685","https://github.com/sparklemotion/nokogiri/issues/693","https://bugzilla.redhat.com/show_bug.cgi?id=1178970","https://github.com/sparklemotion/nokogiri","https://nokogiri.org/CHANGELOG.html#154-2012-06-12"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-6wj9-77wq-jq7p","url":"https://osv.dev/vulnerability/GHSA-6wj9-77wq-jq7p"}],"summary":"Nokogiri is vulnerable to XML External Entity (XXE) attack"}