{"action":"Upgrade http to 0.6.4 or later.","affected":[{"fixed":"0.7.3","introduced":"0.7.0"},{"fixed":"0.6.4","introduced":"0"}],"component":"http","cve_ids":["CVE-2015-1828"],"ecosystem":"RubyGems","epss":0.01521,"exploited":false,"fixed_versions":["0.7.3","0.6.4"],"ghsa_id":"GHSA-6wpv-cj6x-v3jw","id":"tcs_01M5KEHDWS39D1WZYWKJ1PNMNJ","modified_at":"2026-04-17T19:16:39.305790Z","published_at":"2018-03-13T16:15:57Z","references":["https://osv.dev/vulnerability/GHSA-6wpv-cj6x-v3jw","https://nvd.nist.gov/vuln/detail/CVE-2015-1828","https://github.com/ruby/openssl/issues/8","https://github.com/httprb/http","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/http/CVE-2015-1828.yml","https://groups.google.com/forum/#!topic/httprb/jkb4oxwZjkU","https://my.diffend.io/gems/http/0.6.3/0.6.4","https://my.diffend.io/gems/http/0.7.2/0.7.3","https://rubysec.com/advisories/http-CVE-2015-1828"],"severity":{"label":"medium","score":5.9},"sources":[{"source":"osv","source_id":"GHSA-6wpv-cj6x-v3jw","url":"https://osv.dev/vulnerability/GHSA-6wpv-cj6x-v3jw"}],"summary":"http vulnerable to Exposure of Sensitive Information to an Unauthorized Actor"}