{"action":"Upgrade sqlite3-ruby to 1.2.4 or later.","affected":[{"fixed":"1.2.4","introduced":"0"}],"component":"sqlite3-ruby","cve_ids":["CVE-2011-0995"],"ecosystem":"RubyGems","epss":0.00378,"exploited":false,"fixed_versions":["1.2.4"],"ghsa_id":"GHSA-6x46-7rrv-m4h8","id":"tcs_01M5KEHEMP6C8BC22NN2FQSRDX","modified_at":"2024-11-29T05:35:29.653770Z","published_at":"2017-10-24T18:33:38Z","references":["https://osv.dev/vulnerability/GHSA-6x46-7rrv-m4h8","https://nvd.nist.gov/vuln/detail/CVE-2011-0995","https://exchange.xforce.ibmcloud.com/vulnerabilities/67263","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/sqlite3-ruby/CVE-2011-0995.yml","https://github.com/schuyler/sqlite3-ruby","https://web.archive.org/web/20110513184951/http://support.novell.com/security/cve/CVE-2011-0995.html","https://web.archive.org/web/20200229151908/http://www.securityfocus.com/bid/47694","https://web.archive.org/web/20201106213407/https://bugzilla.novell.com/show_bug.cgi?id=685928","https://www.suse.com/security/cve/CVE-2011-0995.html"],"severity":{"label":"low"},"sources":[{"source":"osv","source_id":"GHSA-6x46-7rrv-m4h8","url":"https://osv.dev/vulnerability/GHSA-6x46-7rrv-m4h8"}],"summary":"sqlite3-ruby uses weak permissions for unspecified files, which allows local users to gain privileges"}