{"action":"Upgrade oauth to 0.5.5 or later.","affected":[{"fixed":"0.5.5","introduced":"0"}],"component":"oauth","cve_ids":["CVE-2016-11086"],"ecosystem":"RubyGems","epss":0.00862,"exploited":false,"fixed_versions":["0.5.5"],"ghsa_id":"GHSA-7359-3c6r-hfc2","id":"tcs_01M5KEHFWF1V0YHQM6DYR22RJK","modified_at":"2023-11-08T03:58:21.880410Z","published_at":"2021-04-22T16:22:15Z","references":["https://osv.dev/vulnerability/GHSA-7359-3c6r-hfc2","https://nvd.nist.gov/vuln/detail/CVE-2016-11086","https://github.com/oauth-xx/oauth-ruby/issues/137","https://github.com/oauth-xx/oauth-ruby/commit/eb5b00a91d4ef0899082fdba929c34ccad6d4ccb","https://github.com/oauth-xx/oauth-ruby","https://github.com/oauth-xx/oauth-ruby/releases/tag/v0.5.5","https://rubygems.org/gems/oauth"],"severity":{"label":"high","score":7.4},"sources":[{"source":"osv","source_id":"GHSA-7359-3c6r-hfc2","url":"https://osv.dev/vulnerability/GHSA-7359-3c6r-hfc2"}],"summary":"Improper Certificate Validation in oauth ruby gem"}