{"action":"Upgrade activerecord to 2.3.15 or later.","affected":[{"fixed":"3.0.14","introduced":"3.0.0.beta"},{"fixed":"3.1.6","introduced":"3.1.0"},{"fixed":"3.2.6","introduced":"3.2.0"},{"fixed":"2.3.15","introduced":"0"}],"component":"activerecord","cve_ids":["CVE-2012-2695"],"ecosystem":"RubyGems","epss":0.02947,"exploited":false,"fixed_versions":["3.0.14","3.1.6","3.2.6","2.3.15"],"ghsa_id":"GHSA-76wq-xw4h-f8wj","id":"tcs_01M5KEHKSB0JSJZWS8XA3BTS9G","modified_at":"2025-01-21T15:34:40.818782Z","published_at":"2017-10-24T18:33:38Z","references":["https://osv.dev/vulnerability/GHSA-76wq-xw4h-f8wj","https://nvd.nist.gov/vuln/detail/CVE-2012-2695","https://github.com/rails/rails/commit/62f81f4d6b3ee40e9887ffd92ab14714bad93f18","https://github.com/rails/rails","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/activerecord/CVE-2012-2695.yml","https://groups.google.com/g/rubyonrails-security/c/l4L0TEVAz1k/m/Vr84sD9B464J","https://groups.google.com/group/rubyonrails-security/msg/aee3413fb038bf56?dmode=source&output=gplain","http://lists.opensuse.org/opensuse-security-announce/2012-08/msg00002.html","http://lists.opensuse.org/opensuse-security-announce/2012-08/msg00014.html","http://lists.opensuse.org/opensuse-security-announce/2012-08/msg00016.html","http://lists.opensuse.org/opensuse-updates/2012-08/msg00046.html","http://rhn.redhat.com/errata/RHSA-2013-0154.html"],"severity":{"label":"high"},"sources":[{"source":"osv","source_id":"GHSA-76wq-xw4h-f8wj","url":"https://osv.dev/vulnerability/GHSA-76wq-xw4h-f8wj"}],"summary":"activerecord vulnerable to SQL Injection"}