{"action":"Upgrade nokogiri to 1.11.4 or later.","affected":[{"fixed":"1.11.4","introduced":"0"}],"component":"nokogiri","cve_ids":["CVE-2021-47996"],"ecosystem":"RubyGems","exploited":false,"fixed_versions":["1.11.4"],"ghsa_id":"GHSA-7rrm-v45f-jp64","id":"tcs_01M5KEHT8G4WR3N56FPKPAGZ26","modified_at":"2026-08-27T11:55:35.816797814Z","published_at":"2021-05-17T20:52:05Z","references":["https://osv.dev/vulnerability/GHSA-7rrm-v45f-jp64","https://github.com/sparklemotion/nokogiri/security/advisories/GHSA-7rrm-v45f-jp64","https://nvd.nist.gov/vuln/detail/CVE-2021-3541","https://github.com/sparklemotion/nokogiri/commit/9b90a8854f74b5f672a437ba0043a503bc259d1b","https://github.com/sparklemotion/nokogiri"],"severity":{"label":"medium"},"sources":[{"source":"osv","source_id":"GHSA-7rrm-v45f-jp64","url":"https://osv.dev/vulnerability/GHSA-7rrm-v45f-jp64"}],"summary":"Nokogiri updates packaged dependency on libxml2 from 2.9.10 to 2.9.12"}