{"action":"Upgrade commonmarker to 0.23.10 or later.","affected":[{"fixed":"0.23.10","introduced":"0"}],"component":"commonmarker","cve_ids":[],"ecosystem":"RubyGems","exploited":false,"fixed_versions":["0.23.10"],"ghsa_id":"GHSA-7vh7-fw88-wj87","id":"tcs_01M5KEHTC1PT7SDWJF7QE14WYF","modified_at":"2024-12-01T05:31:38.658446Z","published_at":"2023-08-08T17:12:00Z","references":["https://osv.dev/vulnerability/GHSA-7vh7-fw88-wj87","https://github.com/gjtorikian/commonmarker/security/advisories/GHSA-7vh7-fw88-wj87","https://github.com/gjtorikian/commonmarker/commit/db8cd377b54541f7fd484d168b7682a282a680f7","https://github.com/github/cmark-gfm/releases/tag/0.29.0.gfm.12","https://github.com/gjtorikian/commonmarker","https://rubygems.org/gems/commonmarker/versions/0.23.10"],"severity":{"label":"medium"},"sources":[{"source":"osv","source_id":"GHSA-7vh7-fw88-wj87","url":"https://osv.dev/vulnerability/GHSA-7vh7-fw88-wj87"}],"summary":"Several quadratic complexity bugs may lead to denial of service in Commonmarker"}