{"action":"Upgrade discordrb to 3.4.3 or later.","affected":[{"fixed":"3.4.3","introduced":"0"}],"component":"discordrb","cve_ids":["CVE-2023-28102"],"ecosystem":"RubyGems","epss":0.02567,"exploited":false,"fixed_versions":["3.4.3"],"ghsa_id":"GHSA-8832-4mm5-x2r6","id":"tcs_01M5KEHYJ6MN2QWSFYV4QG7DGT","modified_at":"2024-03-14T20:57:06.696893Z","published_at":"2024-03-14T20:37:58Z","references":["https://osv.dev/vulnerability/GHSA-8832-4mm5-x2r6","https://nvd.nist.gov/vuln/detail/CVE-2023-28102","https://github.com/shardlab/discordrb/commit/91e13043ffa89227c3fcdc3408f06da237d28c95","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/discordrb/CVE-2023-28102.yml","https://github.com/shardlab/discordrb","https://securitylab.github.com/advisories","https://securitylab.github.com/advisories/GHSL-2022-094_discordrb"],"severity":{"label":"critical","score":9.6},"sources":[{"source":"osv","source_id":"GHSA-8832-4mm5-x2r6","url":"https://osv.dev/vulnerability/GHSA-8832-4mm5-x2r6"}],"summary":"discordrb OS Command Injection vulnerability"}