{"action":"Upgrade rack-contrib to 2.5.0 or later.","affected":[{"fixed":"2.5.0","introduced":"0"}],"component":"rack-contrib","cve_ids":["CVE-2024-35231"],"ecosystem":"RubyGems","epss":0.00668,"exploited":false,"fixed_versions":["2.5.0"],"ghsa_id":"GHSA-8c8q-2xw3-j869","id":"tcs_01M5KEHZVSDPDRRSKZJ1VJD1MH","modified_at":"2026-09-10T03:50:13.574187132Z","published_at":"2024-05-28T15:48:43Z","references":["https://osv.dev/vulnerability/GHSA-8c8q-2xw3-j869","https://github.com/rack/rack-contrib/security/advisories/GHSA-8c8q-2xw3-j869","https://nvd.nist.gov/vuln/detail/CVE-2024-35231","https://github.com/rack/rack-contrib/commit/0eec2a9836329051c6742549e65a94a4c24fe6f7","https://github.com/rack/rack-contrib","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/rack-contrib/CVE-2024-35231.yml"],"severity":{"label":"high","score":8.6},"sources":[{"source":"osv","source_id":"GHSA-8c8q-2xw3-j869","url":"https://osv.dev/vulnerability/GHSA-8c8q-2xw3-j869"}],"summary":"rack-contrib vulnerable to Denial of Service due to the unconstrained value of the incoming \"profiler_runs\" parameter"}