{"action":"Upgrade publify_core to 10.0.2 or later.","affected":[{"fixed":"10.0.2","introduced":"0"}],"component":"publify_core","cve_ids":["CVE-2024-39311"],"ecosystem":"RubyGems","epss":0.00271,"exploited":false,"fixed_versions":["10.0.2"],"ghsa_id":"GHSA-8fm5-gg2f-f66q","id":"tcs_01M5KEJ144XYDT22S2RCRNG5A5","modified_at":"2026-09-10T03:50:23.115790816Z","published_at":"2025-03-28T16:34:33Z","references":["https://osv.dev/vulnerability/GHSA-8fm5-gg2f-f66q","https://github.com/publify/publify/security/advisories/GHSA-8fm5-gg2f-f66q","https://nvd.nist.gov/vuln/detail/CVE-2024-39311","https://github.com/publify/publify"],"severity":{"label":"medium","score":5.4},"sources":[{"source":"osv","source_id":"GHSA-8fm5-gg2f-f66q","url":"https://osv.dev/vulnerability/GHSA-8fm5-gg2f-f66q"},{"source":"nvd","source_id":"CVE-2024-39311","url":"https://nvd.nist.gov/vuln/detail/CVE-2024-39311"}],"summary":"Publify Vulnerable To Cross-Site Scripting (XSS) Via Redirects Requiring User Interaction"}