{"action":"Upgrade logstash to 1.4.2 or later.","affected":[{"fixed":"1.4.2","introduced":"1.0.14"}],"component":"logstash","cve_ids":["CVE-2014-4326"],"ecosystem":"RubyGems","epss":0.03297,"exploited":false,"fixed_versions":["1.4.2"],"ghsa_id":"GHSA-8qhq-rq4j-8prj","id":"tcs_01M5KEJ3X7FBNTWTDJR5EB60AN","modified_at":"2025-04-16T17:18:13Z","published_at":"2022-05-14T00:58:13Z","references":["https://osv.dev/vulnerability/GHSA-8qhq-rq4j-8prj","https://nvd.nist.gov/vuln/detail/CVE-2014-4326","https://github.com/elastic/logstash","https://web.archive.org/web/20140804031140/http://www.elasticsearch.org/blog/logstash-1-4-2","https://web.archive.org/web/20201207013408/http://www.securityfocus.com/archive/1/532841/100/0/threaded","https://www.elastic.co/community/security"],"severity":{"label":"high"},"sources":[{"source":"osv","source_id":"GHSA-8qhq-rq4j-8prj","url":"https://osv.dev/vulnerability/GHSA-8qhq-rq4j-8prj"}],"summary":"Elasticsearch Logstash allows remote attackers to execute arbitrary commands"}