{"action":"Upgrade activesupport to 2.2.3 or later.","affected":[{"fixed":"2.2.3","introduced":"2.0.0"},{"fixed":"2.3.4","introduced":"2.3.0"}],"component":"activesupport","cve_ids":["CVE-2009-3009"],"ecosystem":"RubyGems","epss":0.03022,"exploited":false,"fixed_versions":["2.2.3","2.3.4"],"ghsa_id":"GHSA-8qrh-h9m2-5fvf","id":"tcs_01M5KEJ4FZ9ABZ94TBNF1PS9NX","modified_at":"2025-04-09T20:37:04.207075Z","published_at":"2017-10-24T18:33:38Z","references":["https://osv.dev/vulnerability/GHSA-8qrh-h9m2-5fvf","https://nvd.nist.gov/vuln/detail/CVE-2009-3009","https://exchange.xforce.ibmcloud.com/vulnerabilities/53036","https://github.com/advisories/GHSA-8qrh-h9m2-5fvf","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/activesupport/CVE-2009-3009.yml","http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=545063","http://groups.google.com/group/rubyonrails-security/msg/7f57cd7794e1d1b4?dmode=source","http://lists.apple.com/archives/security-announce/2010//Mar/msg00001.html","http://lists.opensuse.org/opensuse-security-announce/2009-10/msg00004.html","http://secunia.com/advisories/36600","http://secunia.com/advisories/36717","http://securitytracker.com/id?1022824","http://support.apple.com/kb/HT4077","http://weblog.rubyonrails.org/2009/9/4/xss-vulnerability-in-ruby-on-rails","http://www.debian.org/security/2009/dsa-1887","http://www.osvdb.org/57666","http://www.securityfocus.com/bid/36278","http://www.vupen.com/english/advisories/2009/2544"],"severity":{"label":"medium"},"sources":[{"source":"osv","source_id":"GHSA-8qrh-h9m2-5fvf#RubyGems/activesupport","url":"https://osv.dev/vulnerability/GHSA-8qrh-h9m2-5fvf"}],"summary":"Cross site scripting that affects rails"}