{"action":"Upgrade puppet to 2.7.26 or later.","affected":[{"fixed":"2.7.26","introduced":"0"},{"fixed":"3.6.2","introduced":"3.0.0"}],"component":"puppet","cve_ids":["CVE-2014-3248"],"ecosystem":"RubyGems","epss":0.00542,"exploited":false,"fixed_versions":["2.7.26","3.6.2"],"ghsa_id":"GHSA-92v7-pq4h-58j5","id":"tcs_01M5KEJ69ZKZA8M4RETTED8NDP","modified_at":"2024-12-02T05:40:00.351658Z","published_at":"2017-10-24T18:33:36Z","references":["https://osv.dev/vulnerability/GHSA-92v7-pq4h-58j5","https://nvd.nist.gov/vuln/detail/CVE-2014-3248","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/facter/CVE-2014-3248.yml","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/hiera/CVE-2014-3248.yml","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/mcollective-client/CVE-2014-3248.yml","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/puppet/CVE-2014-3248.yml","https://web.archive.org/web/20141129061319/http://www.securityfocus.com/bid/68035","https://web.archive.org/web/20150204183209/http://rowediness.com/2014/06/13/cve-2014-3248-a-little-problem-with-puppet","https://web.archive.org/web/20150907182402/http://puppetlabs.com/security/cve/cve-2014-3248"],"severity":{"label":"medium"},"sources":[{"source":"osv","source_id":"GHSA-92v7-pq4h-58j5#RubyGems/puppet","url":"https://osv.dev/vulnerability/GHSA-92v7-pq4h-58j5"}],"summary":"facter, hiera, mcollective-client, and puppet affected by untrusted search path vulnerability"}