{"action":"Upgrade actionpack to 2.3.5 or later.","affected":[{"fixed":"3.0.16","introduced":"3.0.0.beta"},{"fixed":"3.1.7","introduced":"3.1.0"},{"fixed":"3.2.7","introduced":"3.2.0"},{"fixed":"2.3.5","introduced":"0"}],"component":"actionpack","cve_ids":["CVE-2012-3424"],"ecosystem":"RubyGems","epss":0.01889,"exploited":false,"fixed_versions":["3.0.16","3.1.7","3.2.7","2.3.5"],"ghsa_id":"GHSA-92w9-2pqw-rhjj","id":"tcs_01M5KEJ6MCQMKH4M6KA3S83P1D","modified_at":"2025-01-22T15:37:57.056044Z","published_at":"2017-10-24T18:33:38Z","references":["https://osv.dev/vulnerability/GHSA-92w9-2pqw-rhjj","https://nvd.nist.gov/vuln/detail/CVE-2012-3424","https://github.com/rails/rails/commit/3719bd3e95523c5518507dbe44f260f252930600","https://github.com/rails/rails","https://groups.google.com/group/rubyonrails-security/msg/244d32f2fa25147d?hl=en&dmode=source&output=gplain","http://lists.opensuse.org/opensuse-updates/2012-08/msg00046.html","http://rhn.redhat.com/errata/RHSA-2013-0154.html","http://weblog.rubyonrails.org/2012/7/26/ann-rails-3-2-7-has-been-released"],"severity":{"label":"medium"},"sources":[{"source":"osv","source_id":"GHSA-92w9-2pqw-rhjj","url":"https://osv.dev/vulnerability/GHSA-92w9-2pqw-rhjj"}],"summary":"actionpack Improper Authentication vulnerability"}