{"action":"Upgrade rack to 2.0.9.2 or later.","affected":[{"fixed":"2.0.9.2","introduced":"2.0.0"},{"fixed":"2.1.4.2","introduced":"2.1.0"},{"fixed":"2.2.6.1","introduced":"2.2.0"},{"fixed":"3.0.4.1","introduced":"3.0.0.0"}],"component":"rack","cve_ids":["CVE-2022-44571"],"ecosystem":"RubyGems","epss":0.01503,"exploited":false,"fixed_versions":["2.0.9.2","2.1.4.2","2.2.6.1","3.0.4.1"],"ghsa_id":"GHSA-93pm-5p5f-3ghx","id":"tcs_01M5KEJ6YEMRTZ4C3D18YFSCA8","modified_at":"2024-12-01T05:24:17.798143Z","published_at":"2023-01-18T18:24:40Z","references":["https://osv.dev/vulnerability/GHSA-93pm-5p5f-3ghx","https://nvd.nist.gov/vuln/detail/CVE-2022-44571","https://discuss.rubyonrails.org/t/cve-2022-44571-possible-denial-of-service-vulnerability-in-rack-content-disposition-parsing/82126","https://github.com/rack/rack","https://github.com/rack/rack/releases/tag/v3.0.4.1","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/rack/CVE-2022-44571.yml","https://www.debian.org/security/2023/dsa-5530"],"severity":{"label":"low"},"sources":[{"source":"osv","source_id":"GHSA-93pm-5p5f-3ghx","url":"https://osv.dev/vulnerability/GHSA-93pm-5p5f-3ghx"}],"summary":"Denial of Service Vulnerability in Rack Content-Disposition parsing"}