{"action":"Upgrade omniauth-saml to 1.10.0 or later.","affected":[{"fixed":"1.10.0","introduced":"0"}],"component":"omniauth-saml","cve_ids":["CVE-2017-11430"],"ecosystem":"RubyGems","epss":0.02435,"exploited":false,"fixed_versions":["1.10.0"],"ghsa_id":"GHSA-94hm-8q65-rmxm","id":"tcs_01M5KEJ7DPRF0DGE485BQ8Q4Q2","modified_at":"2024-02-16T08:19:52.688707Z","published_at":"2019-07-05T21:11:43Z","references":["https://osv.dev/vulnerability/GHSA-94hm-8q65-rmxm","https://nvd.nist.gov/vuln/detail/CVE-2017-11430","https://duo.com/blog/duo-finds-saml-vulnerabilities-affecting-multiple-implementations","https://github.com/omniauth/omniauth-saml","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/omniauth-saml/CVE-2017-11430.yml","https://www.kb.cert.org/vuls/id/475445"],"severity":{"label":"high","score":7.7},"sources":[{"source":"osv","source_id":"GHSA-94hm-8q65-rmxm","url":"https://osv.dev/vulnerability/GHSA-94hm-8q65-rmxm"}],"summary":"OmniAuth-SAML authentication bypass via incorrect XML canonicalization and DOM traversal"}