{"action":"Upgrade opensearch-ruby to 2.0.2 or later.","affected":[{"fixed":"2.0.2","introduced":"2.0.0"}],"component":"opensearch-ruby","cve_ids":["CVE-2022-31115"],"ecosystem":"RubyGems","epss":0.01617,"exploited":false,"fixed_versions":["2.0.2"],"ghsa_id":"GHSA-977c-63xq-cgw3","id":"tcs_01M5KEJ8HF2G007GA1JFJX4BXE","modified_at":"2024-02-22T05:30:03.876682Z","published_at":"2022-07-05T20:41:26Z","references":["https://osv.dev/vulnerability/GHSA-977c-63xq-cgw3","https://github.com/opensearch-project/opensearch-ruby/security/advisories/GHSA-977c-63xq-cgw3","https://nvd.nist.gov/vuln/detail/CVE-2022-31115","https://github.com/opensearch-project/opensearch-ruby/pull/77","https://github.com/opensearch-project/opensearch-ruby/commit/d74a98b45c037671e8819fa87f6a6423458ab08a","https://github.com/opensearch-project/opensearch-ruby","https://github.com/opensearch-project/opensearch-ruby/compare/v2.0.1...v2.0.2","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/opensearch-ruby/CVE-2022-31115.yml","https://staaldraad.github.io/post/2021-01-09-universal-rce-ruby-yaml-load-updated"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"GHSA-977c-63xq-cgw3","url":"https://osv.dev/vulnerability/GHSA-977c-63xq-cgw3"}],"summary":"opensearch-ruby 2.x before 2.0.2 vulnerable to unsafe YAML deserialization"}