{"action":"Upgrade actionpack to 7.0.8.1 or later.","affected":[{"fixed":"7.0.8.1","introduced":"7.0.0"},{"fixed":"7.1.3.1","introduced":"7.1.0"}],"component":"actionpack","cve_ids":["CVE-2024-26143"],"ecosystem":"RubyGems","epss":0.01034,"exploited":false,"fixed_versions":["7.0.8.1","7.1.3.1"],"ghsa_id":"GHSA-9822-6m93-xqf4","id":"tcs_01M5KEJ94RVWTP5XAQ2AMAVQHS","modified_at":"2026-06-08T23:45:17.847969876Z","published_at":"2024-02-27T21:41:12Z","references":["https://osv.dev/vulnerability/GHSA-9822-6m93-xqf4","https://github.com/rails/rails/security/advisories/GHSA-9822-6m93-xqf4","https://nvd.nist.gov/vuln/detail/CVE-2024-26143","https://github.com/rails/rails/commit/4c83b331092a79d58e4adffe4be5f250fa5782cc","https://github.com/rails/rails/commit/5187a9ef51980ad1b8e81945ebe0462d28f84f9e","https://discuss.rubyonrails.org/t/possible-xss-vulnerability-in-action-controller/84947","https://github.com/rails/rails","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/actionpack/CVE-2024-26143.yml","https://security.netapp.com/advisory/ntap-20240510-0004"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"GHSA-9822-6m93-xqf4","url":"https://osv.dev/vulnerability/GHSA-9822-6m93-xqf4"}],"summary":"Rails has possible XSS Vulnerability in Action Controller"}