{"action":"Upgrade puma to 5.6.9 or later.","affected":[{"fixed":"5.6.9","introduced":"0"},{"fixed":"6.4.3","introduced":"6.0.0"}],"component":"puma","cve_ids":["CVE-2024-45614"],"ecosystem":"RubyGems","epss":0.0064,"exploited":false,"fixed_versions":["5.6.9","6.4.3"],"ghsa_id":"GHSA-9hf4-67fc-4vf4","id":"tcs_01M5KEJCMVVREW8118ES58F15R","modified_at":"2026-09-10T03:50:56.027397803Z","published_at":"2024-09-20T14:40:16Z","references":["https://osv.dev/vulnerability/GHSA-9hf4-67fc-4vf4","https://github.com/puma/puma/security/advisories/GHSA-9hf4-67fc-4vf4","https://nvd.nist.gov/vuln/detail/CVE-2024-45614","https://github.com/puma/puma/commit/cac3fd18cf29ed43719ff5d52d9cfec215f0a043","https://github.com/puma/puma/commit/f196b23be24712fb8fb16051cc124798cc84f70e","https://github.com/puma/puma","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/puma/CVE-2024-45614.yml","https://lists.debian.org/debian-lts-announce/2024/11/msg00004.html","https://nginx.org/en/docs/http/ngx_http_core_module.html#underscores_in_headers"],"severity":{"label":"medium","score":5.4},"sources":[{"source":"osv","source_id":"GHSA-9hf4-67fc-4vf4","url":"https://osv.dev/vulnerability/GHSA-9hf4-67fc-4vf4"}],"summary":"Puma's header normalization allows for client to clobber proxy set headers"}