{"action":"Upgrade rubygems-update to 1.8.23.1 or later.","affected":[{"fixed":"1.8.23.1","introduced":"0"},{"fixed":"1.8.26","introduced":"1.8.24"},{"fixed":"2.0.8","introduced":"2.0.0"},{"fixed":"2.1.0","introduced":"2.1.0.rc.1"}],"component":"rubygems-update","cve_ids":["CVE-2013-4287"],"ecosystem":"RubyGems","epss":0.03331,"exploited":false,"fixed_versions":["1.8.23.1","1.8.26","2.0.8","2.1.0"],"ghsa_id":"GHSA-9j7m-rjqx-48vh","id":"tcs_01M5KEJDPYMWXY0VZNMTNQM6SE","modified_at":"2024-11-29T05:42:20.333898Z","published_at":"2022-05-14T01:08:27Z","references":["https://osv.dev/vulnerability/GHSA-9j7m-rjqx-48vh","https://nvd.nist.gov/vuln/detail/CVE-2013-4287","https://github.com/rubygems/rubygems/commit/938a7e31ac73655845ab9045629ff3f580a125da","https://github.com/rubygems/rubygems/commit/b697536f2455e8c8853cf5cf8a1017a36031ed67","https://github.com/rubygems/rubygems/commit/b9baec03145aed684d1cd3c87dcac3cc06becd9b","https://github.com/rubygems/rubygems/commit/ed733bc379d75620f5be4213f89d1d7b38be3191","https://github.com/rubygems/rubygems/blob/03a074e8838683f45611b119fd8f363aa44fe2fd/CHANGELOG.md","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/rubygems-update/CVE-2013-4287.yml","https://web.archive.org/web/20160806152839/https://puppet.com/security/cve/cve-2013-4287","http://blog.rubygems.org/2013/09/09/CVE-2013-4287.html","http://rhn.redhat.com/errata/RHSA-2013-1427.html","http://rhn.redhat.com/errata/RHSA-2013-1441.html","http://rhn.redhat.com/errata/RHSA-2013-1523.html","http://rhn.redhat.com/errata/RHSA-2013-1852.html","http://rhn.redhat.com/errata/RHSA-2014-0207.html","http://www.openwall.com/lists/oss-security/2013/09/10/1"],"severity":{"label":"medium"},"sources":[{"source":"osv","source_id":"GHSA-9j7m-rjqx-48vh","url":"https://osv.dev/vulnerability/GHSA-9j7m-rjqx-48vh"}],"summary":"RubyGems Regular Expression Denial of Service vulnerability"}