{"action":"Upgrade json to 2.10.2 or later.","affected":[{"fixed":"2.10.2","introduced":"2.10.0"}],"component":"json","cve_ids":["CVE-2025-27788"],"ecosystem":"RubyGems","epss":0.0072,"exploited":false,"fixed_versions":["2.10.2"],"ghsa_id":"GHSA-9m3q-rhmv-5q44","id":"tcs_01M5KEJE0WWRT3MBZFGS1CQ3JV","modified_at":"2026-09-10T03:49:48.468812643Z","published_at":"2025-03-12T15:35:23Z","references":["https://osv.dev/vulnerability/GHSA-9m3q-rhmv-5q44","https://github.com/ruby/json/security/advisories/GHSA-9m3q-rhmv-5q44","https://nvd.nist.gov/vuln/detail/CVE-2025-27788","https://github.com/ruby/json/commit/c56db31f800d5d508389793e69682f99749dbadf","https://github.com/ruby/json","https://github.com/ruby/json/releases/tag/v2.10.2","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/json/CVE-2025-27788.yml"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-9m3q-rhmv-5q44","url":"https://osv.dev/vulnerability/GHSA-9m3q-rhmv-5q44"}],"summary":"Out-of-bounds Read in Ruby JSON Parser"}