{"action":"Upgrade rails to 2.2.2 or later.","affected":[{"fixed":"2.2.2","introduced":"0"},{"fixed":"2.3.5","introduced":"2.3.0"}],"component":"rails","cve_ids":["CVE-2009-4214"],"ecosystem":"RubyGems","epss":0.03022,"exploited":false,"fixed_versions":["2.2.2","2.3.5"],"ghsa_id":"GHSA-9p3v-wf2w-v29c","id":"tcs_01M5KEJEMVJMF5T8E5HD5ED817","modified_at":"2025-04-09T20:05:53.148849Z","published_at":"2017-10-24T18:33:38Z","references":["https://osv.dev/vulnerability/GHSA-9p3v-wf2w-v29c","https://nvd.nist.gov/vuln/detail/CVE-2009-4214","https://github.com/advisories/GHSA-9p3v-wf2w-v29c","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/rails/CVE-2009-4214.yml","http://github.com/rails/rails","http://github.com/rails/rails/commit/bfe032858077bb2946abe25e95e485ba6da86bd5","http://groups.google.com/group/rubyonrails-security/browse_thread/thread/4d4f71f2aef4c0ab?pli=1","http://lists.apple.com/archives/security-announce/2010//Mar/msg00001.html","http://lists.opensuse.org/opensuse-security-announce/2010-03/msg00004.html","http://secunia.com/advisories/37446","http://secunia.com/advisories/38915","http://support.apple.com/kb/HT4077","http://weblog.rubyonrails.org/2009/11/30/ruby-on-rails-2-3-5-released","http://www.debian.org/security/2011/dsa-2260","http://www.debian.org/security/2011/dsa-2301","http://www.openwall.com/lists/oss-security/2009/11/27/2","http://www.openwall.com/lists/oss-security/2009/12/08/3","http://www.securityfocus.com/bid/37142","http://www.securitytracker.com/id?1023245","http://www.vupen.com/english/advisories/2009/3352"],"severity":{"label":"medium"},"sources":[{"source":"osv","source_id":"GHSA-9p3v-wf2w-v29c","url":"https://osv.dev/vulnerability/GHSA-9p3v-wf2w-v29c"}],"summary":"Moderate severity vulnerability that affects rails"}