{"action":"Upgrade loofah to 2.3.1 or later.","affected":[{"fixed":"2.3.1","introduced":"0"}],"component":"loofah","cve_ids":["CVE-2019-15587"],"ecosystem":"RubyGems","epss":0.01561,"exploited":false,"fixed_versions":["2.3.1"],"ghsa_id":"GHSA-c3gv-9cxf-6f57","id":"tcs_01M5KEJKD0SQ22F7VA596R0DVM","modified_at":"2024-02-16T08:24:36.818396Z","published_at":"2019-11-05T23:58:25Z","references":["https://osv.dev/vulnerability/GHSA-c3gv-9cxf-6f57","https://nvd.nist.gov/vuln/detail/CVE-2019-15587","https://github.com/flavorjones/loofah/issues/171","https://github.com/flavorjones/loofah/commit/0c6617af440879ce97440f6eb6c58636456dc8ec","https://hackerone.com/reports/709009","https://github.com/flavorjones/loofah","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/loofah/CVE-2019-15587.yml","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/4WK2UG7ORKRQOJ6E4XJ2NVIHYJES6BYZ","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/XMCWPLYPNIWYAY443IZZJ4IHBBLIHBP5","https://security.netapp.com/advisory/ntap-20191122-0003","https://usn.ubuntu.com/4498-1","https://www.debian.org/security/2019/dsa-4554"],"severity":{"label":"medium","score":5.4},"sources":[{"source":"osv","source_id":"GHSA-c3gv-9cxf-6f57","url":"https://osv.dev/vulnerability/GHSA-c3gv-9cxf-6f57"}],"summary":"Loofah Allows Cross-site Scripting"}