{"action":"Upgrade ruby-lsp to 0.26.9 or later.","affected":[{"fixed":"0.26.9","introduced":"0"}],"component":"ruby-lsp","cve_ids":["CVE-2026-34060"],"ecosystem":"RubyGems","epss":0.00479,"exploited":false,"fixed_versions":["0.26.9"],"ghsa_id":"GHSA-c4r5-fxqw-vh93","id":"tcs_01M5KEJME0HRQY6FENTYMVXTPC","modified_at":"2026-03-31T18:49:02.441618Z","published_at":"2026-03-27T19:43:14Z","references":["https://osv.dev/vulnerability/GHSA-c4r5-fxqw-vh93","https://github.com/Shopify/ruby-lsp/security/advisories/GHSA-c4r5-fxqw-vh93","https://nvd.nist.gov/vuln/detail/CVE-2026-34060","https://github.com/Shopify/ruby-lsp","https://github.com/Shopify/ruby-lsp/releases/tag/v0.26.9","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/ruby-lsp/CVE-2026-34060.yml"],"severity":{"label":"high"},"sources":[{"source":"osv","source_id":"GHSA-c4r5-fxqw-vh93","url":"https://osv.dev/vulnerability/GHSA-c4r5-fxqw-vh93"}],"summary":"Ruby LSP has arbitrary code execution through branch setting"}