{"action":"Upgrade puppet to 2.7.13 or later.","affected":[{"fixed":"2.7.13","introduced":"2.7.1"}],"component":"puppet","cve_ids":["CVE-2012-1989"],"ecosystem":"RubyGems","epss":0.00402,"exploited":false,"fixed_versions":["2.7.13"],"ghsa_id":"GHSA-c5qq-g673-5p49","id":"tcs_01M5KEJMQQ8QQJNKB98C1G9ZZW","modified_at":"2024-11-29T05:42:00.071511Z","published_at":"2017-10-24T18:33:38Z","references":["https://osv.dev/vulnerability/GHSA-c5qq-g673-5p49","https://nvd.nist.gov/vuln/detail/CVE-2012-1989","https://exchange.xforce.ibmcloud.com/vulnerabilities/74797","https://github.com/puppetlabs/puppet","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/puppet/CVE-2012-1989.yml","https://hermes.opensuse.org/messages/15087408","https://web.archive.org/web/20120415105345/http://www.securityfocus.com/bid/52975","https://www.puppet.com/security/cve/cve-2012-1989-arbitrary-file-write-access","http://lists.opensuse.org/opensuse-updates/2012-05/msg00012.html","http://projects.puppetlabs.com/issues/13606","http://projects.puppetlabs.com/projects/1/wiki/Release_Notes#2.7.13","http://puppetlabs.com/security/cve/cve-2012-1989","http://ubuntu.com/usn/usn-1419-1"],"severity":{"label":"low"},"sources":[{"source":"osv","source_id":"GHSA-c5qq-g673-5p49","url":"https://osv.dev/vulnerability/GHSA-c5qq-g673-5p49"}],"summary":"Puppet allows local users to overwrite arbitrary files via a symlink attack"}