{"action":"Upgrade rails-html-sanitizer to 1.6.1 or later.","affected":[{"fixed":"1.6.1","introduced":"1.6.0"}],"component":"rails-html-sanitizer","cve_ids":["CVE-2024-53988"],"ecosystem":"RubyGems","epss":0.00447,"exploited":false,"fixed_versions":["1.6.1"],"ghsa_id":"GHSA-cfjx-w229-hgx5","id":"tcs_01M5KEJR2PQXC23Q45CYS2A340","modified_at":"2024-12-03T18:50:33Z","published_at":"2024-12-02T21:48:42Z","references":["https://osv.dev/vulnerability/GHSA-cfjx-w229-hgx5","https://github.com/rails/rails-html-sanitizer/security/advisories/GHSA-cfjx-w229-hgx5","https://nvd.nist.gov/vuln/detail/CVE-2024-53988","https://github.com/rails/rails-html-sanitizer/commit/a0a3e8b76b696446ffc6bffcff3bc7b7c6393c72","https://github.com/rails/rails-html-sanitizer","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/rails-html-sanitizer/CVE-2024-53988.yml"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"GHSA-cfjx-w229-hgx5","url":"https://osv.dev/vulnerability/GHSA-cfjx-w229-hgx5"},{"source":"nvd","source_id":"CVE-2024-53988","url":"https://nvd.nist.gov/vuln/detail/CVE-2024-53988"}],"summary":"rails-html-sanitizer has XSS vulnerability with certain configurations"}