{"action":"Upgrade puppet to 2.7.23 or later.","affected":[{"fixed":"2.7.23","introduced":"2.7.0"},{"fixed":"3.2.4","introduced":"3.2.0"}],"component":"puppet","cve_ids":["CVE-2013-4761"],"ecosystem":"RubyGems","epss":0.01643,"exploited":false,"fixed_versions":["2.7.23","3.2.4"],"ghsa_id":"GHSA-cj43-9h3w-v976","id":"tcs_01M5KEJRSP039AN8Z0WH9STE0S","modified_at":"2024-11-29T05:36:41.183107Z","published_at":"2017-10-24T18:33:37Z","references":["https://osv.dev/vulnerability/GHSA-cj43-9h3w-v976","https://nvd.nist.gov/vuln/detail/CVE-2013-4761","https://github.com/puppetlabs/puppet","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/puppet/CVE-2013-4761.yml","https://www.puppet.com/security/cve/cve-2013-4761-resourcetype-remote-code-execution-vulnerability","http://lists.opensuse.org/opensuse-security-announce/2014-01/msg00009.html","http://puppetlabs.com/security/cve/cve-2013-4761","http://rhn.redhat.com/errata/RHSA-2013-1283.html","http://rhn.redhat.com/errata/RHSA-2013-1284.html","http://www.debian.org/security/2013/dsa-2761"],"severity":{"label":"medium"},"sources":[{"source":"osv","source_id":"GHSA-cj43-9h3w-v976","url":"https://osv.dev/vulnerability/GHSA-cj43-9h3w-v976"}],"summary":"Puppet allows remote attackers to execute arbitrary Ruby programs from the master via the resource_type service"}