{"action":"Upgrade user_agent_parser to 2.6.0 or later.","affected":[{"fixed":"2.6.0","introduced":"0"}],"component":"user_agent_parser","cve_ids":["CVE-2020-5243"],"ecosystem":"RubyGems","epss":0.02289,"exploited":false,"fixed_versions":["2.6.0"],"ghsa_id":"GHSA-cmcx-xhr8-3w9p","id":"tcs_01M5KEJT171HW9T893S1Q7SMW9","modified_at":"2026-07-08T06:27:49.976052814Z","published_at":"2020-02-20T23:26:10Z","references":["https://osv.dev/vulnerability/GHSA-cmcx-xhr8-3w9p","https://github.com/ua-parser/uap-core/security/advisories/GHSA-cmcx-xhr8-3w9p","https://github.com/ua-parser/uap-ruby/security/advisories/GHSA-pcqq-5962-hvcw","https://nvd.nist.gov/vuln/detail/CVE-2020-5243","https://github.com/ua-parser/uap-core/commit/0afd61ed85396a3b5316f18bfd1edfaadf8e88e1","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/user_agent_parser/CVE-2020-5243.yml"],"severity":{"label":"medium","score":5.7},"sources":[{"source":"osv","source_id":"GHSA-cmcx-xhr8-3w9p#RubyGems/user_agent_parser","url":"https://osv.dev/vulnerability/GHSA-cmcx-xhr8-3w9p"}],"summary":"Denial of Service in uap-core when processing crafted User-Agent strings"}