{"action":"Upgrade camaleon_cms to 2.8.1 or later.","affected":[{"fixed":"2.8.1","introduced":"0"}],"component":"camaleon_cms","cve_ids":["CVE-2024-46987"],"ecosystem":"RubyGems","epss":0.1456,"exploited":false,"fixed_versions":["2.8.1"],"ghsa_id":"GHSA-cp65-5m9r-vc2c","id":"tcs_01M5KEJTB3JPZ2EBYD3KCEF988","modified_at":"2025-04-17T23:23:18.562873Z","published_at":"2024-09-18T15:46:53Z","references":["https://osv.dev/vulnerability/GHSA-cp65-5m9r-vc2c","https://github.com/owen2345/camaleon-cms/security/advisories/GHSA-cp65-5m9r-vc2c","https://nvd.nist.gov/vuln/detail/CVE-2024-46987","https://github.com/owen2345/camaleon-cms/commit/071b1b09d6d61ab02a5960b1ccafd9d9c2155a3e","https://codeql.github.com/codeql-query-help/ruby/rb-path-injection","https://github.com/owen2345/camaleon-cms","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/camaleon_cms/CVE-2024-46987.yml","https://owasp.org/www-community/attacks/Path_Traversal","https://securitylab.github.com/advisories/GHSL-2024-182_GHSL-2024-186_Camaleon_CMS","https://www.reddit.com/r/rails/comments/1exwtdm/camaleon_cms_281_has_been_released"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"GHSA-cp65-5m9r-vc2c","url":"https://osv.dev/vulnerability/GHSA-cp65-5m9r-vc2c"}],"summary":"Camaleon CMS vulnerable to arbitrary path traversal (GHSL-2024-183)"}