{"action":"Upgrade omniauth-saml to 1.10.5 or later.","affected":[{"fixed":"2.1.2","introduced":"2.0.0"},{"fixed":"1.10.5","introduced":"0"},{"fixed":"2.2.1","introduced":"2.2.0"}],"component":"omniauth-saml","cve_ids":[],"ecosystem":"RubyGems","exploited":false,"fixed_versions":["2.1.2","1.10.5","2.2.1"],"ghsa_id":"GHSA-cvp8-5r8g-fhvq","id":"tcs_01M5KEJWB69FE6CZBP9G91ZFAV","modified_at":"2026-08-07T08:11:59.192768697Z","published_at":"2024-09-11T21:08:26Z","references":["https://osv.dev/vulnerability/GHSA-cvp8-5r8g-fhvq","https://github.com/SAML-Toolkits/ruby-saml/security/advisories/GHSA-jw9c-mfg7-9rx2","https://github.com/omniauth/omniauth-saml/security/advisories/GHSA-cvp8-5r8g-fhvq","https://github.com/omniauth/omniauth-saml/commit/4274e9d57e65f2dcaae4aa3b2accf831494f2ddd","https://github.com/omniauth/omniauth-saml/commit/6c681fd082ab3daf271821897a40ab3417382e29","https://github.com/omniauth/omniauth-saml","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/omniauth-saml/GHSA-cvp8-5r8g-fhvq.yml"],"severity":{"label":"critical","score":10},"sources":[{"source":"osv","source_id":"GHSA-cvp8-5r8g-fhvq","url":"https://osv.dev/vulnerability/GHSA-cvp8-5r8g-fhvq"}],"summary":"omniauth-saml vulnerable to Improper Verification of Cryptographic Signature"}