{"action":"Upgrade puppet to 2.7.22 or later.","affected":[{"fixed":"2.7.22","introduced":"2.7.0"},{"fixed":"3.2.2","introduced":"3.2.0"}],"component":"puppet","cve_ids":["CVE-2013-3567"],"ecosystem":"RubyGems","epss":0.03408,"exploited":false,"fixed_versions":["2.7.22","3.2.2"],"ghsa_id":"GHSA-f7p5-w2cr-7cp7","id":"tcs_01M5KEJZHK1N5XK00165PQDFMM","modified_at":"2024-11-29T05:36:23.437616Z","published_at":"2017-10-24T18:33:37Z","references":["https://osv.dev/vulnerability/GHSA-f7p5-w2cr-7cp7","https://nvd.nist.gov/vuln/detail/CVE-2013-3567","https://github.com/puppetlabs/puppet","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/puppet/CVE-2013-3567.yml","https://puppetlabs.com/security/cve/cve-2013-3567","https://www.puppet.com/security/cve/cve-2013-3567-unauthenticated-remote-code-execution-vulnerability","http://lists.opensuse.org/opensuse-security-announce/2013-08/msg00002.html","http://lists.opensuse.org/opensuse-security-announce/2013-08/msg00019.html","http://rhn.redhat.com/errata/RHSA-2013-1283.html","http://rhn.redhat.com/errata/RHSA-2013-1284.html","http://www.debian.org/security/2013/dsa-2715","http://www.ubuntu.com/usn/USN-1886-1"],"severity":{"label":"high"},"sources":[{"source":"osv","source_id":"GHSA-f7p5-w2cr-7cp7","url":"https://osv.dev/vulnerability/GHSA-f7p5-w2cr-7cp7"}],"summary":"Puppet Improper Input Validation vulnerability"}