{"action":"Upgrade css_parser to 1.22.0 or later.","affected":[{"fixed":"2.1.0","introduced":"2.0.0"},{"fixed":"1.22.0","introduced":"0"}],"component":"css_parser","cve_ids":["CVE-2026-44312"],"ecosystem":"RubyGems","epss":0.00146,"exploited":false,"fixed_versions":["2.1.0","1.22.0"],"ghsa_id":"GHSA-ff6c-w6qf-7xqc","id":"tcs_01M5KEK0EPG1JVJS98Q60DYSGR","modified_at":"2026-06-08T23:30:16.074085735Z","published_at":"2026-05-07T02:06:49Z","references":["https://osv.dev/vulnerability/GHSA-ff6c-w6qf-7xqc","https://github.com/premailer/css_parser/security/advisories/GHSA-ff6c-w6qf-7xqc","https://nvd.nist.gov/vuln/detail/CVE-2026-44312","https://github.com/premailer/css_parser/issues/185","https://github.com/premailer/css_parser/commit/35e689c904225add78e0c488cf04bad052666449","https://github.com/premailer/css_parser/commit/e0c95d5abe91b237becb90ff316531a6547ada18","https://github.com/premailer/css_parser","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/css_parser/CVE-2026-44312.yml"],"severity":{"label":"medium","score":5.8},"sources":[{"source":"osv","source_id":"GHSA-ff6c-w6qf-7xqc","url":"https://osv.dev/vulnerability/GHSA-ff6c-w6qf-7xqc"}],"summary":"CSS Parser: Improper Certificate Validation allows MITM injection of remote CSS content"}