{"action":"Upgrade omniauth-oauth2 to 1.1.1 or later.","affected":[{"fixed":"1.1.1","introduced":"0"}],"component":"omniauth-oauth2","cve_ids":["CVE-2012-6134"],"ecosystem":"RubyGems","epss":0.01196,"exploited":false,"fixed_versions":["1.1.1"],"ghsa_id":"GHSA-fgmx-8h93-26fh","id":"tcs_01M5KEK1QWNKB7SG19H93JVM6M","modified_at":"2024-12-05T05:39:59.934310Z","published_at":"2017-10-24T18:33:37Z","references":["https://osv.dev/vulnerability/GHSA-fgmx-8h93-26fh","https://nvd.nist.gov/vuln/detail/CVE-2012-6134","https://github.com/Shopify/omniauth-shopify-oauth2/pull/1","https://github.com/intridea/omniauth-oauth2/pull/25","https://github.com/Shopify/omniauth-shopify-oauth2","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/omniauth-oauth2/CVE-2012-6134.yml","https://web.archive.org/web/20170312020947/https://gist.github.com/homakov/3673012","http://rubysec.github.io/advisories/CVE-2012-6134","http://seclists.org/oss-sec/2013/q1/304"],"severity":{"label":"medium"},"sources":[{"source":"osv","source_id":"GHSA-fgmx-8h93-26fh","url":"https://osv.dev/vulnerability/GHSA-fgmx-8h93-26fh"}],"summary":"omniauth-oauth2 Cross-Site Request Forgery vulnerability"}