{"action":"Upgrade octokit to 4.25.0 or later.","affected":[{"fixed":"4.25.0","introduced":"4.23.0"}],"component":"octokit","cve_ids":["CVE-2022-31072"],"ecosystem":"RubyGems","epss":0.00251,"exploited":false,"fixed_versions":["4.25.0"],"ghsa_id":"GHSA-g28x-pgr3-qqx6","id":"tcs_01M5KEK6Z917ZHDVMS232SA1ZX","modified_at":"2023-11-08T04:09:24.861105Z","published_at":"2022-06-15T21:24:16Z","references":["https://osv.dev/vulnerability/GHSA-g28x-pgr3-qqx6","https://github.com/octokit/octokit.rb/security/advisories/GHSA-g28x-pgr3-qqx6","https://nvd.nist.gov/vuln/detail/CVE-2022-31072","https://github.com/octokit/octokit.rb/commit/1c8edecc9cf23d1ceb959d91a416a69f55ce7d55","https://github.com/octokit/octokit.rb","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/octokit/CVE-2022-31072.yml"],"severity":{"label":"low","score":2.5},"sources":[{"source":"osv","source_id":"GHSA-g28x-pgr3-qqx6","url":"https://osv.dev/vulnerability/GHSA-g28x-pgr3-qqx6"}],"summary":"Octokit gem published with world-writable files"}