{"action":"Upgrade cocoapods-downloader to 1.6.2 or later.","affected":[{"fixed":"1.6.2","introduced":"0"}],"component":"cocoapods-downloader","cve_ids":["CVE-2022-21223"],"ecosystem":"RubyGems","epss":0.01687,"exploited":false,"fixed_versions":["1.6.2"],"ghsa_id":"GHSA-g397-v4w5-4m79","id":"tcs_01M5KEK79MS86R6B6MFFX1GQ5S","modified_at":"2026-07-08T06:50:01.938540582Z","published_at":"2022-04-02T00:00:13Z","references":["https://osv.dev/vulnerability/GHSA-g397-v4w5-4m79","https://nvd.nist.gov/vuln/detail/CVE-2022-21223","https://github.com/CocoaPods/cocoapods-downloader/pull/127","https://github.com/CocoaPods/cocoapods-downloader","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/cocoapods-downloader/CVE-2022-21223.yml","https://snyk.io/vuln/SNYK-RUBY-COCOAPODSDOWNLOADER-2414280"],"severity":{"label":"high","score":8.1},"sources":[{"source":"osv","source_id":"GHSA-g397-v4w5-4m79","url":"https://osv.dev/vulnerability/GHSA-g397-v4w5-4m79"}],"summary":"Command injection in cocoapods-downloader"}