{"action":"Upgrade websocket-extensions to 0.1.5 or later.","affected":[{"fixed":"0.1.5","introduced":"0"}],"component":"websocket-extensions","cve_ids":["CVE-2020-7663"],"ecosystem":"RubyGems","epss":0.04639,"exploited":false,"fixed_versions":["0.1.5"],"ghsa_id":"GHSA-g6wq-qcwm-j5g2","id":"tcs_01M5KEK81YRN580GCMAPMZYGVV","modified_at":"2026-07-08T06:50:03.986630807Z","published_at":"2020-06-05T14:21:29Z","references":["https://osv.dev/vulnerability/GHSA-g6wq-qcwm-j5g2","https://github.com/faye/websocket-extensions-ruby/security/advisories/GHSA-g6wq-qcwm-j5g2","https://nvd.nist.gov/vuln/detail/CVE-2020-7663","https://github.com/faye/websocket-extensions-ruby/commit/aa156a439da681361ed6f53f1a8131892418838b","https://blog.jcoglan.com/2020/06/02/redos-vulnerability-in-websocket-extensions","https://github.com/faye/websocket-extensions-ruby","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/websocket-extensions/CVE-2020-7663.yml","https://lists.debian.org/debian-lts-announce/2020/08/msg00031.html","https://snyk.io/vuln/SNYK-RUBY-WEBSOCKETEXTENSIONS-570830","https://usn.ubuntu.com/4502-1"],"severity":{"label":"high","score":8.2},"sources":[{"source":"osv","source_id":"GHSA-g6wq-qcwm-j5g2","url":"https://osv.dev/vulnerability/GHSA-g6wq-qcwm-j5g2"}],"summary":"Regular Expression Denial of Service in websocket-extensions (RubyGem)"}