{"action":"Upgrade phlex to 1.4.2 or later.","affected":[{"fixed":"1.10.1","introduced":"1.10.0"},{"fixed":"1.9.2","introduced":"1.9.0"},{"fixed":"1.8.3","introduced":"1.8.0"},{"fixed":"1.7.2","introduced":"1.7.0"},{"fixed":"1.6.3","introduced":"1.6.0"},{"fixed":"1.5.3","introduced":"1.5.0"},{"fixed":"1.4.2","introduced":"0"}],"component":"phlex","cve_ids":["CVE-2024-32463"],"ecosystem":"RubyGems","epss":0.00575,"exploited":false,"fixed_versions":["1.10.1","1.9.2","1.8.3","1.7.2","1.6.3","1.5.3","1.4.2"],"ghsa_id":"GHSA-g7xq-xv8c-h98c","id":"tcs_01M5KEK8BJKZ1G3Q1BZ2C9CYVH","modified_at":"2026-09-10T03:50:11.506169823Z","published_at":"2024-04-17T00:20:23Z","references":["https://osv.dev/vulnerability/GHSA-g7xq-xv8c-h98c","https://github.com/phlex-ruby/phlex/security/advisories/GHSA-g7xq-xv8c-h98c","https://nvd.nist.gov/vuln/detail/CVE-2024-32463","https://github.com/phlex-ruby/phlex/commit/9e3f5b980655817993682e409cbda72956d865cb","https://developer.mozilla.org/en-US/docs/Web/HTTP/Headers/Content-Security-Policy","https://developer.mozilla.org/en-US/docs/Web/HTTP/Headers/Content-Security-Policy#unsafe-inline","https://github.com/phlex-ruby/phlex","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/phlex/CVE-2024-32463.yml"],"severity":{"label":"high","score":7.1},"sources":[{"source":"osv","source_id":"GHSA-g7xq-xv8c-h98c","url":"https://osv.dev/vulnerability/GHSA-g7xq-xv8c-h98c"}],"summary":"Cross-site Scripting (XSS) possible due to improper sanitisation of `href` attributes on `<a>` tags"}