{"action":"Upgrade puppet to 2.6.17 or later.","affected":[{"fixed":"2.6.17","introduced":"0"},{"fixed":"2.7.18","introduced":"2.7.0"}],"component":"puppet","cve_ids":["CVE-2012-3865"],"ecosystem":"RubyGems","epss":0.01882,"exploited":false,"fixed_versions":["2.6.17","2.7.18"],"ghsa_id":"GHSA-g89m-3wjw-h857","id":"tcs_01M5KEK8THKNQD41TCJF388JW2","modified_at":"2024-11-29T05:24:24.540245Z","published_at":"2017-10-24T18:33:37Z","references":["https://osv.dev/vulnerability/GHSA-g89m-3wjw-h857","https://nvd.nist.gov/vuln/detail/CVE-2012-3865","https://github.com/puppetlabs/puppet/commit/554eefc55f57ed2b76e5ee04d8f194d36f6ee67f","https://github.com/puppetlabs/puppet/commit/d80478208d79a3e6d6cb1fbc525e24817fe8c4c6","https://bugzilla.redhat.com/show_bug.cgi?id=839131","https://github.com/puppetlabs/puppet","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/CVE-2012-3865.yml","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/puppet/CVE-2012-3865.yml","https://www.puppet.com/security/cve/overview-cve-2012-3865-arbitrary-file-delete/dos-puppet-master","http://lists.opensuse.org/opensuse-security-announce/2012-08/msg00006.html","http://lists.opensuse.org/opensuse-updates/2012-07/msg00036.html","http://puppetlabs.com/security/cve/cve-2012-3865","http://www.debian.org/security/2012/dsa-2511","http://www.ubuntu.com/usn/USN-1506-1"],"severity":{"label":"low"},"sources":[{"source":"osv","source_id":"GHSA-g89m-3wjw-h857","url":"https://osv.dev/vulnerability/GHSA-g89m-3wjw-h857"}],"summary":"Puppet vulnerable to Path Traversal"}