{"action":"Upgrade actionpack to 6.0.3.7 or later.","affected":[{"fixed":"6.0.3.7","introduced":"6.0.0"},{"fixed":"6.1.3.2","introduced":"6.1.0"}],"component":"actionpack","cve_ids":["CVE-2021-22902"],"ecosystem":"RubyGems","epss":0.02868,"exploited":false,"fixed_versions":["6.0.3.7","6.1.3.2"],"ghsa_id":"GHSA-g8ww-46x2-2p65","id":"tcs_01M5KEK94EM9EGX42VAYXK4JHM","modified_at":"2024-02-16T08:21:28.149273Z","published_at":"2021-05-05T19:48:21Z","references":["https://osv.dev/vulnerability/GHSA-g8ww-46x2-2p65","https://nvd.nist.gov/vuln/detail/CVE-2021-22902","https://hackerone.com/reports/1138654","https://discuss.rubyonrails.org/t/cve-2021-22902-possible-denial-of-service-vulnerability-in-action-dispatch/77866","https://github.com/rails/rails/releases/tag/v6.0.3.7","https://github.com/rails/rails/releases/tag/v6.1.3.2","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/actionpack/CVE-2021-22902.yml","https://groups.google.com/g/rubyonrails-security/c/_5ID_ld9u1c"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-g8ww-46x2-2p65","url":"https://osv.dev/vulnerability/GHSA-g8ww-46x2-2p65"}],"summary":"Denial of Service in Action Dispatch"}