{"action":"Upgrade rubyzip to 1.2.1 or later.","affected":[{"fixed":"1.2.1","introduced":"0"}],"component":"rubyzip","cve_ids":["CVE-2017-5946"],"ecosystem":"RubyGems","epss":0.03441,"exploited":false,"fixed_versions":["1.2.1"],"ghsa_id":"GHSA-gcqq-w6gr-h9j9","id":"tcs_01M5KEKA8TQYFT93AHMPPFBHQY","modified_at":"2024-02-16T08:12:37.749196Z","published_at":"2017-10-24T18:33:35Z","references":["https://osv.dev/vulnerability/GHSA-gcqq-w6gr-h9j9","https://nvd.nist.gov/vuln/detail/CVE-2017-5946","https://github.com/rubyzip/rubyzip/issues/315","https://github.com/rubyzip/rubyzip/commit/ce4208fdecc2ad079b05d3c49d70fe6ed1d07016","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/rubyzip/CVE-2017-5946.yml","https://github.com/rubyzip/rubyzip","https://github.com/rubyzip/rubyzip/releases","https://web.archive.org/web/20200227185727/http://www.securityfocus.com/bid/96445","http://www.debian.org/security/2017/dsa-3801"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-gcqq-w6gr-h9j9","url":"https://osv.dev/vulnerability/GHSA-gcqq-w6gr-h9j9"}],"summary":"Directory traversal vulnerability in RubyZip"}