{"action":"Upgrade cgi to 0.3.5.1 or later.","affected":[{"fixed":"0.3.5.1","introduced":"0"},{"fixed":"0.3.7","introduced":"0.3.6"},{"fixed":"0.4.2","introduced":"0.4.0"}],"component":"cgi","cve_ids":["CVE-2025-27219"],"ecosystem":"RubyGems","epss":0.00849,"exploited":false,"fixed_versions":["0.3.5.1","0.3.7","0.4.2"],"ghsa_id":"GHSA-gh9q-2xrm-x6qv","id":"tcs_01M5KEKAW1SFM62BEZ9W7ACXZ4","modified_at":"2026-09-10T03:49:48.446743004Z","published_at":"2025-03-03T20:53:43Z","references":["https://osv.dev/vulnerability/GHSA-gh9q-2xrm-x6qv","https://nvd.nist.gov/vuln/detail/CVE-2025-27219","https://github.com/ruby/cgi/pull/52","https://github.com/ruby/cgi/pull/53","https://github.com/ruby/cgi/pull/54","https://hackerone.com/reports/2936778","https://github.com/ruby/cgi","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/cgi/CVE-2025-27219.yml","https://lists.debian.org/debian-lts-announce/2025/03/msg00008.html","https://www.cve.org/CVERecord?id=CVE-2025-27219"],"severity":{"label":"medium","score":5.8},"sources":[{"source":"osv","source_id":"GHSA-gh9q-2xrm-x6qv","url":"https://osv.dev/vulnerability/GHSA-gh9q-2xrm-x6qv"}],"summary":"CGI has Denial of Service (DoS) potential in Cookie.parse"}