{"action":"Upgrade puppet to 5.5.19 or later.","affected":[{"fixed":"6.13.0","introduced":"6.0.0"},{"fixed":"5.5.19","introduced":"0"}],"component":"puppet","cve_ids":["CVE-2020-7942"],"ecosystem":"RubyGems","epss":0.00801,"exploited":false,"fixed_versions":["6.13.0","5.5.19"],"ghsa_id":"GHSA-gqvf-892r-vjm5","id":"tcs_01M5KEKCSPTDWBA5HVKV7ETN76","modified_at":"2024-02-22T05:39:45.872465Z","published_at":"2021-04-13T15:42:19Z","references":["https://osv.dev/vulnerability/GHSA-gqvf-892r-vjm5","https://nvd.nist.gov/vuln/detail/CVE-2020-7942","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/puppet/CVE-2020-7942.yml","https://puppet.com/security/cve/CVE-2020-7942"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"GHSA-gqvf-892r-vjm5","url":"https://osv.dev/vulnerability/GHSA-gqvf-892r-vjm5"}],"summary":"Improper Certificate Validation in Puppet"}