{"action":"Upgrade sidekiq to 5.2.0 or later.","affected":[{"fixed":"5.2.0","introduced":"0"},{"fixed":"6.2.1","introduced":"6.0.0"}],"component":"sidekiq","cve_ids":["CVE-2021-30151"],"ecosystem":"RubyGems","epss":0.04158,"exploited":false,"fixed_versions":["5.2.0","6.2.1"],"ghsa_id":"GHSA-grh7-935j-hg6w","id":"tcs_01M5KEKD3TG3MBGNM0NGHZEG2D","modified_at":"2023-11-08T04:05:44.931120Z","published_at":"2021-10-06T17:47:17Z","references":["https://osv.dev/vulnerability/GHSA-grh7-935j-hg6w","https://nvd.nist.gov/vuln/detail/CVE-2021-30151","https://github.com/mperham/sidekiq/issues/4852","https://github.com/mperham/sidekiq/commit/64f70339d1dcf50a55c00d36bfdb61d97ec63ed8","https://github.com/mperham/sidekiq","https://lists.debian.org/debian-lts-announce/2022/03/msg00015.html"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"GHSA-grh7-935j-hg6w","url":"https://osv.dev/vulnerability/GHSA-grh7-935j-hg6w"}],"summary":"Cross-site Scripting in Sidekiq"}