{"action":"Upgrade rubygems-update to 2.7.6 or later.","affected":[{"fixed":"2.7.6","introduced":"0"}],"component":"rubygems-update","cve_ids":["CVE-2018-1000077"],"ecosystem":"RubyGems","epss":0.03595,"exploited":false,"fixed_versions":["2.7.6"],"ghsa_id":"GHSA-gv86-43rv-79m2","id":"tcs_01M5KEKD927H45ZE0TVYYQDFW2","modified_at":"2024-03-12T05:33:22.932684Z","published_at":"2022-05-14T01:01:09Z","references":["https://osv.dev/vulnerability/GHSA-gv86-43rv-79m2","https://nvd.nist.gov/vuln/detail/CVE-2018-1000077","https://github.com/jruby/jruby/commit/0b06b48ab4432237ce5fc1bef47f2c6bcf7843f7","https://github.com/rubygems/rubygems/commit/5971b486d4dbb2bad5d3445b3801c456eb0ce183","https://github.com/rubygems/rubygems/commit/feadefc2d351dcb95d6492f5ad17ebca546eb964","https://www.debian.org/security/2018/dsa-4259","https://www.debian.org/security/2018/dsa-4219","https://usn.ubuntu.com/3621-1","https://lists.debian.org/debian-lts-announce/2019/05/msg00028.html","https://lists.debian.org/debian-lts-announce/2018/07/msg00012.html","https://lists.debian.org/debian-lts-announce/2018/04/msg00023.html","https://lists.debian.org/debian-lts-announce/2018/04/msg00001.html","https://lists.debian.org/debian-lts-announce/2018/04/msg00000.html","https://access.redhat.com/errata/RHSA-2020:0663","https://access.redhat.com/errata/RHSA-2020:0591","https://access.redhat.com/errata/RHSA-2020:0542","https://access.redhat.com/errata/RHSA-2019:2028","https://access.redhat.com/errata/RHSA-2018:3731","https://access.redhat.com/errata/RHSA-2018:3730","https://access.redhat.com/errata/RHSA-2018:3729","http://blog.rubygems.org/2018/02/15/2.7.6-released.html","http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00036.html"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"GHSA-gv86-43rv-79m2","url":"https://osv.dev/vulnerability/GHSA-gv86-43rv-79m2"}],"summary":"RubyGems Improper Input Validation vulnerability"}