{"action":"Upgrade sidekiq to 7.0.8 or later.","affected":[{"fixed":"7.0.8","introduced":"7.0.4"}],"component":"sidekiq","cve_ids":["CVE-2023-1892"],"ecosystem":"RubyGems","epss":0.02742,"exploited":false,"fixed_versions":["7.0.8"],"ghsa_id":"GHSA-h3r8-h5qw-4r35","id":"tcs_01M5KEKG48KKWFAKQ545NH2QWC","modified_at":"2024-05-01T13:31:16.043478Z","published_at":"2023-04-21T06:30:19Z","references":["https://osv.dev/vulnerability/GHSA-h3r8-h5qw-4r35","https://nvd.nist.gov/vuln/detail/CVE-2023-1892","https://github.com/sidekiq/sidekiq/commit/458fdf74176a9881478c48dc5cf0269107b22214","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/sidekiq/CVE-2023-1892.yml","https://github.com/sidekiq/sidekiq","https://github.com/sidekiq/sidekiq/blob/main/Changes.md#708","https://huntr.dev/bounties/e35e5653-c429-4fb8-94a3-cbc123ae4777"],"severity":{"label":"high","score":8.3},"sources":[{"source":"osv","source_id":"GHSA-h3r8-h5qw-4r35","url":"https://osv.dev/vulnerability/GHSA-h3r8-h5qw-4r35"}],"summary":"sidekiq vulnerable to cross-site scripting"}