{"action":"Upgrade rack to 2.0.6 or later.","affected":[{"fixed":"2.0.6","introduced":"2.0.4"}],"component":"rack","cve_ids":["CVE-2018-16470"],"ecosystem":"RubyGems","epss":0.02033,"exploited":false,"fixed_versions":["2.0.6"],"ghsa_id":"GHSA-hg78-4f6x-99wq","id":"tcs_01M5KEKKGNWD8BVX68Z6MMJK9M","modified_at":"2024-02-16T08:02:29.993945Z","published_at":"2018-11-15T15:58:58Z","references":["https://osv.dev/vulnerability/GHSA-hg78-4f6x-99wq","https://nvd.nist.gov/vuln/detail/CVE-2018-16470","https://access.redhat.com/errata/RHSA-2019:3172","https://github.com/rack/rack","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/rack/CVE-2018-16470.yml","https://groups.google.com/forum/#!msg/rubyonrails-security/U_x-YkfuVTg/xhvYAmp6AAAJ","https://groups.google.com/forum/#!topic/ruby-security-ann/Dz4sRl-ktKk"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-hg78-4f6x-99wq","url":"https://osv.dev/vulnerability/GHSA-hg78-4f6x-99wq"}],"summary":"Rack vulnerable to Denial of Service"}