{"action":"Upgrade rack to 2.0.9.1 or later.","affected":[{"fixed":"2.0.9.1","introduced":"1.2"},{"fixed":"2.1.4.1","introduced":"2.1"},{"fixed":"2.2.3.1","introduced":"2.2"}],"component":"rack","cve_ids":["CVE-2022-30122"],"ecosystem":"RubyGems","epss":0.02231,"exploited":false,"fixed_versions":["2.0.9.1","2.1.4.1","2.2.3.1"],"ghsa_id":"GHSA-hxqx-xwvh-44m2","id":"tcs_01M5KEKQT48NTFBJZFJPDTA7EG","modified_at":"2024-02-18T05:27:39.361222Z","published_at":"2022-05-27T16:36:52Z","references":["https://osv.dev/vulnerability/GHSA-hxqx-xwvh-44m2","https://nvd.nist.gov/vuln/detail/CVE-2022-30122","https://discuss.rubyonrails.org/t/cve-2022-30122-denial-of-service-vulnerability-in-rack-multipart-parsing/80729","https://github.com/rack/rack","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/rack/CVE-2022-30122.yml","https://groups.google.com/g/ruby-security-ann/c/L2Axto442qk","https://security.gentoo.org/glsa/202310-18","https://security.netapp.com/advisory/ntap-20231208-0012","https://www.debian.org/security/2023/dsa-5530"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-hxqx-xwvh-44m2","url":"https://osv.dev/vulnerability/GHSA-hxqx-xwvh-44m2"}],"summary":"Denial of Service Vulnerability in Rack Multipart Parsing"}